Learn Courses My Dashboard

Xcode Simulator language settings

I’ve been looking for a solution to this but have yet to find it.

I’m residing in Finland, have my MacBook’s region set to Finland, have a Finnish keyboard, but primary language is set to English. I’m a native English speaker and do dev in English.

Every time I run the simulator, it defaults to Finnish, and thus testing any text input is always in Finnish. Not the end of the world, but it’s one of those little annoyances that add up over time.

I know I can reset the language manually in the simulated phone’s settings, or manually change the keyboard, but while test and running the simulator frequently, that quickly becomes an extra time consuming step.

Is there a way to permanently set the Simulator language?

You can edit the scheme of your app and set the language

Click on the app, like right next to where you click on the simulator and then in the general settings you can set the language

Hi Mikaela, I think I tried that, is this what you mean?

Click Edit Scheme

and then go to the Run option

when I do that and run the simulator I still get Finnish keyboard as primary and have to manually switch it over to the English one.

Yes that’s the settings I was thinking of, that’s interesting, I thought that would’ve changed the keyboard too

In the simulator go to the menu bar
I/O > Keyboard > uncheck “use same keyboard language as macOS”

And re run?

1 Like

Strange, you’d really think that would work, but doesn’t seem to.

Ah OK, I think it’s working now. I also had to remove the Finnish Keyboard from the simulator. But this time it seems to be staying gone, whereas before it would be back anytime I rebuilt the app.

Fingers crossed, and thanks for the help!