Xcode's 14.3 xcrun xcdevice doesn't recognise my iOS 16.4 device

Hi there,
i develop iOS and Android mobile apps with Flutter, where i deploy the iOS apps not within Xcode but from IntelliJ.
After upgrading Xcode to version 14.3 my iPhone with iOS 16.4.1 is not listed anymore as deployment target in IntelliJ (although it is still shown when i’m in Xcode).
When going back to Xcode 14.2 (using the Xcodes app) the device is listed without any problems.
I’ve noticed that IntelliJ must use some sort of this command to determine the available simulators and connected devices: xcrun xcdevice list
When i run this command manually on the command line the device isn’t listed as well.

I’ve tried a lot of things but nothing worked so far. Other developers (who also deploy their apps outside Xcode) also have this problem.
I’ve contacted Apple, but they are not able to reproduce this issue on their side so far.

For more insights i’ve opened tickets here and here as well.

If anybody has an idea what is going wrong or missing here, please let me know.
At the moment i can still work with Xcode 14.2, but somewhen in the future this probably won’t be possible anymore.
Btw. i’ve also tried with Xcode 15 Beta, but also with that version the device is not listed.