Databases Courses Module 2 Lesson 1

Hi! This is a question that pertains to the installation of the pods. More specifically, I have an M1 Mac and I have trying to install this pod ‘Firebase/Firestore’ to my Xcode project. But I don’t see an .xcworkspace file being created. Can you please help me?


Hi @Pratham_Hebbar

Welcome to the Code Crew community.

What steps have you taken so far to install cocoapods on your machine?

Hi Chris,

I followed the video
I have cocoapods version 1.10.0 installed
I have a pod file in my xcode project
But for some reason, I can’t install pod ‘Firebase/Firestore’ and see an .xcworkspace file in my xcode project


Everything was going smoothly until I tried to install the pod ‘Firebase/Firestore’ and could not see the .xcworkspace file in my xcode project.

P.S. I have an M1 Mac
Please reply ASAP

Pratham Hebbar

Can you show the contents of your Podfile.

After you edited the Podfile did you go back to the Terminal window and type in the command:

pod install

yes of course! Just give me a second.

I edited my previous reply. Did you issue the command pod install in the terminal window?

Hi Chris,
Yes I did type in the command pod install in the terminal window and for some reason. I dont see an .xcworkspace file in my xcode project!

What diagnostics were output to the terminal window during the pod install process?

Screen Shot 2020-12-06 at 2.56.51 PM

I am also kinda curious. Do you have an M1 Mac and were you successful in installing that specific pod?
If the answer to both of those questions are true, can you please type out the procedures you followed to install the specific pod?


If you type the command ls -l and press return, what is the output?

Screen Shot 2020-12-06 at 3.10.49 PM

So the project name is NotebookJournal.
What is the content of the Podfile in that directory? if you type the command cat Podfile it will list the contents.

Screen Shot 2020-12-06 at 3.17.56 PM

Hmmmm, everything looks OK in that Podfile so the pod install should work.

Delete the Pods folder and try the command pod install again.

hi Chris,

so I tried doing that and I typed pod install in the terminal window and it did not work for some reason

Can you show the output in the terminal window. Resize the window to show all of the output from the command pod install onwards.

Screen Shot 2020-12-06 at 3.49.53 PM