Learn Courses My Dashboard

iPhone 7 run issue

Hi All,

I have updated the iOS 15. After that I can’t able to run the code in iPhone 7.

Getting error as Making iPhone7 ready for development.

Anybody help me to resolve this.

Thanks in Advance.

@Siviani

What is the exact error you are getting? Add a screenshot or paste the error in a reply as text.
Have you installed Xcode 13 or are you still using Xcode 12.5.1?

Yes I have installed the xcode 13.
When I run with iphone 7 getting error as like this…

That’s normal. Wait for it to finish. It might take a little while.

Thankyou!

Hi Chris,

Still I am getting this error.
Any suggestions?

@Sivani

What version of Xcode are you using?

Xcode 13

Try closing Xcode and reboot your Mac. Also reboot your iPhone 7 before you re-attach it to your Mac.

Yes I did.
But again not running in iPhone 7.

Try to delete the iPhone 7 simulator and add it back

I am trying to run in device.
I can run through simulator.

Oh, check to make sure your iPhone is added to you development in Apple to use as a test device

Yes it is added

Try to remove the trusted account (your dev account) in the settings
Delete the app from your phone and then try to build it in the iPhone again

The message says that it’s an iPhone 7 and you said that earlier. Now you say that you’re not running in iPhone 7. Which is it?

If you are running on a physical iPhone 7, you should reboot it (not just power off and on). I have seen this message several times and rebooting has always worked for me.

I was trying to run the app in iPhone 7 device through xcode.

On xocde 12.5, it was running fine in device.
But once I updated to macos 11 .6 and xcode 13.
I am getting this error.

I also tried to reboot the device.
Still I am facing this issue.

When I connected the device with the system and trying to run the code with xcode.

Even I could not able to see the app icon in device. Before that itself, I am facing this issue.

@Sivani
Did you wait for Xcode finish “Making the iPhone7 ready for development” or did you click on “Cancel Running”?

I have been waited for some hours.
But it’s not completed.