Xcode bug issue

Hello Team,

Ive just relaunched my xcode project after a few weeks. Xcode is telling me there is “no editor” and the build also fails.

Not entirely sure why this has happened. Can anyone help?


Hi Saihra,

Can you post a screenshot of the project as you are seeing it in the Xcode window.

If you tap on the red error indicator you will see an expanded view of the error in the left pane. Hopefully that will point you in the right direction. Post a screenshot if it does not make sense.

I used the free trial of Sketch for my assets. That trial ended but i didnt realise that my assets would then cease to exists after the free trail. That may be the problem.

I would not have thought that the images would be unusable if you had dragged them into your Assets catalogue.

Thats what i thought, but it seems to have rendered my whole projected uneditable.

Is there anything at all in your Assets catalogue?

Nothing, it wont open when i click on it, neither will the other files.

Oh so you cannot click on any of the .swift files either?

Nope, no files will open.

There is something more fundamental wrong in that case. Have you tried closing and re-launching Xcode?

Yes tried a few times

OK what about re-starting your Mac?

Just restarted it. Still have the same problem.

That’s weird. Have you installed any macOS software updates recently?

last update i did was about 3 months ago

i installed macOS 3 months ago

Hmmmmm… my thinking was that there might be a permissions issue hence that question.

Can you create a new project? Just anything to see if Xcode is able to do just that.

created a new project, all seems fine on that end